东林博客

GoFrame 1.8 升级到1.9踩坑记

本博客是由GF 1.8.2框架写的,今天GF升级到了1.9,所以晚上也相应的做了升级,来尝鲜1.9我最期待的中间件功能。

首先修改go.mod ,把

github.com/gogf/gf v1.8.2

修改为:

github.com/gogf/gf v1.9.0

执行 go build,报错:

F:\www\macnie\gblog>go build
build gblog: cannot load 
github.com/gogf/gf/g: cannot find module providing package github.com/gogf/g
f/g

这是因为1.9修改了包路径,解决办法如下:

Goland 使用Ctrl+R,全局替换:

github.com/gogf/gf/g/  为  github.com/gogf/gf/


"github.com/gogf/gf/g" 为  "github.com/gogf/gf/frame/g"

注意双引号

再次build,成功。

{{tip}}